テイルズウィーバー

ランダム型宝箱アイテム

タイアップ限定!
宝箱「このすば」
510(水)更新!

定期メンテナンス

毎週水曜日 10:30~14:00
※メンテナンス中はゲームをプレイできません。

自由掲示板 | COMMUNITY

ゲーム開始後、画面が真っ暗・・・

イソレット
サーバー:
ミストラル
投稿者:
RARAMUMU さん
閲覧数:
2073

すみません、Win7→Win10になってからTWが出来ず困っております・・・

win7Pro→現在Win10Pro64bit(クリーンインストール済み)
i7 2700k メモリ8G GTX970 SSD120G HDD2T 各ドライバ最新
DirectX12 ブラウザGoogle chrome 画面サイズ1280x1024

状況:
→ChromeWebからゲームスタート→ゲーム開始を押す
→右下Xingcode起動表示
→TWクライアントウィンドウが立ち上がるのですが、真っ暗で音も出ず、(応答なし)と表示されます。
SSDにデフォルトインストールし直す✖ HDDも試すも✖
管理者権限で起動✖ IEから起動✖
フルスクリーンモード✖ウィンドウモード✖
他のオンラインゲームは問題なくプレイ出来てます。(Steam等)
試しにCSOをインストールしたところ、こちらも問題なくプレイ出来ました。
原因が分からず、なにかご助言をいただければ幸いです

スクラップを追加
コメントを投稿
サーバー:
エルフィンタ
投稿者:
十六茶モコ さん

TWは一番最初にムービーが流れます。あれが曲者なんです。
もともとWindows10は動画再生が7に比べて劣っているので
ffdshowなどのコーデックパックを入れてみてください。

それでもダメでしたら
TalesWeaverフォルダ内の「tales2.avi」 「Tales.avi」を削除してみてください。

サーバー:
ミストラル
投稿者:
校長 さん

解決策2:
クリーンインストールが問題の場合、
DirectX9.0cを入れると解決する場合もあります
Win10に同梱されているDirectXは、一部古いOCXが存在しません
これにより、WinXP世代の古いアプリケーションなどが
そのままでは動かないことがあります
お手持ちの最新パッケージソフトに付属のものか、
まいくろそふとの公式ページから探して(※これが曲者で大変難しい)、
何とかして入れてみて下さい

つまり、このゲームの開発パッケージは、
ランタイムなどの作りがWinXP世代のままだとバレています

サーバー:
ミストラル
投稿者:
校長 さん

追伸:
ダウンロードするのがまぁ難しいんだなこれが・・・
キーワードは、
"DirectX End-User Runtimes (June 2010)"
これでもうまくいかなかったら、お手上げー

このコメントは削除されました。

サーバー:
ミストラル
投稿者:
RARAMUMU さん

ご助言ありがとうございます。
早速試してみました。
DirectX End-User Runtimes June 2010 インストール✖
フォルダ内のtales2.aviとTales.aviを削除✖
ffdshow導入✖
DirectX9.0cはwindows10でインストール出来ず・・・

おそらく、校長さんのおっしゃるクリーンインストールからの
ランタイム欠けが原因な気がしてきました。
幸い、サブPCがWin7(64bit)のままでTWをプレイ出来ているので、
サブから必要なランタイムを持ってこられればなんとか・・・

ただWin10で適用させられるかが難しそうですが・・・

サーバー:
エルフィンタ
投稿者:
ラディッシュ さん

DirectXのランタイムでしたら、MSサイトのDirectX Web Installer をダウンロードして
実行すれば、不足分を自動で適用してくれますよ。私のWin10はすべてこれを実行しました。
「dxwebsetup」で検索してみてください。
他のゲームが動いていることからDirectXが原因か微妙ですが…うまくいくとよいですね。

サーバー:
ミストラル
投稿者:
校長 さん

そんな方法もあるんですね
自分はWin7Home64bit→Win10Home64bitのアップグレードインストールですが、
それでも動かない古いゲームをなんとかするため、
・頑張ってDirectX9.0cのランタイムををダウンロード
・7Zipで解凍
・setup
この手順で入れました
さらに、それでも足りないOCXを手動で入れる力業で、
その古いゲームが動くようになりました
そんなグロいことをせずとも、
VB6ランタイムを最新版にするだけで良かったのかもしれません

サーバー:
ミストラル
投稿者:
RARAMUMU さん

お騒がせしてすみません。クライアント起動問題自己解決しました。
OSからクリーンインストールし直したところ、とりあえず起動できるようになりました。
結局のところ、原因が良く分からなかった(-_-;)

→Win7Pro64bitクリーンインストール→ ランタイム(June 2010)インストール→TW起動確認
→Win10Pro64bitアップグレード→TW起動確認→ランタイム(June 2010)インストール→TW起動確認(今ここ)

ただひとつ、Windows 10 Anniversary Updateを控えているのですが
インストールして大丈夫か不安です・・・

サーバー:
エルフィンタ
投稿者:
ラディッシュ さん

AnniversaryUpdateを行うことに心配がある場合に考えられる対策案を。()内はデメリットです。

①現在の状態をイメージファイル化して戻せるようにしておく(NGで戻す→アップデートできていない)
②Windows7とのデュアルブートを検討する(ディスク容量が必要、起動時にOS選択が必要)
③諦めてTWはサブマシンで遊ぶ(どうしてもスペックが低くなる)

不満が出にくいのは②、面倒が嫌いでしたら③、でしょうか。
いずれにしてもMSアカウントで認証できるようになる為一度はAnniversaryUpdateを行ったほうが良いかと。

サーバー:
エルフィンタ
投稿者:
ラディッシュ さん

あ、あともうひとつ。
GTX970ではなくi7の内蔵グラフィックで試す、という手もアリかと。

これで問題ないなら970との組み合わせで発生していることになります。
まぁ…Virtuの設定の問題だったりする可能性もありますけどね。

サーバー:
ローゼンバーグ
投稿者:
なやとれーぃ さん

当初明確な回答ができないので回答は控えていましたが...

基本的にWindows 10 及び Anniversary Update自体でのTW動作は問題ないてす。
Windows 10 Anniversaryで問題なく利用ができているからです。
2台利用していて、1台はメインでWin8.1からのアッブデート、もうひとつはサブで元からWin10後Anniversaryにして一切問題が出ていないからです。
最初のような動画やDXでの問題は一切でていなく、クリーンインストールでの状態で問題なく動作しているからです。
とくに追加でのインストールは一切必要なく利用できているので(DirectX9.0cのランタイムは入れてません)、多分、質問者さんのPCの固有の問題だと思ったので回答は控えていました。
もし問題がでていたら、Win10ユーザーから同様な苦情がたくさん出ていると思うので...

サーバー:
ローゼンバーグ
投稿者:
なやとれーぃ さん

文字数制限があったのでレスにて追加。

Win10が出た頃の当初はTWが動作するかわからなかったので、アップデートを控えていましたが、公式で対応がしたこと Anniversary も対応表明したことと、ユーザー側も問題がでなかったので(公式対応前はfpsが異常に下がってゲームができないくらいの問題が出ていたこともあった)基本問題なく動作します。

ですのでシステムが不安定、相性問題等の固有の問題かと思います。
OSのクリーンインストールで改善されたのであればその通りなので、Anniversary Update自体は問題ないかと思います。
もしまた問題があったのであれば、固有の問題ですのでややこしいですね。

並び替え
記事表示数
件名 投稿者 日付 閲覧数
ローゼンバーグ
ヒメハジロ
447
ゼルナ
あいおおお
3102
ミストラル
校長
2192
ミストラル
ラグザーノ
1341
エルフィンタ
花華院みき
2067
モエン
虎牙音色
1850
ミストラル
校長
1740
ミストラル
借り暮らし
2307
ローゼンバーグ
emitti
1083
ゼルナ
xxリーリィxx
3030
ゼルナ
とどめの一撃
1431
ローゼンバーグ
kikiliee
951
ゼルナ
七海哉太
2334
ミストラル
校長
1851
ローゼンバーグ
ブッキーナ
2394
ミストラル
なにゃねえ
1747
エルフィンタ
etwtewt
3250
ミストラル
きるみぃべぃべ
2036
ミストラル
校長
1761
モエン
ろずりあ
4383
掲示板に投稿する